Eclipse Logo I have just discovered that if you use the deb based distribution of Eclipse for Ubuntu Linux (6.10 in my case) then Junit4 is disabled. This also seems to apply to other Debian based distributions I think. The fix is to download Eclipse from the Eclipse web site and unpack. Then run Eclipse from the unpacked location. You need to have previously installed JDK 1.5 of better.